Mikrotik: настраиваем безопасное соединение www-ssl (HTTPS)

Курс «Настройка оборудования MikroTik»

Освоить MikroTik вы можете с помощью онлайн-курса «Настройка оборудования MikroTik». В курсе изучаются все темы из официальной программы MTCNA. Автор – официальный тренер MikroTik. Материал подходит и тем, кто уже давно работает с оборудованием MikroTik, и тем, кто еще не держал его в руках. В состав входят 162 видеоурока, 45 лабораторных работ, вопросы для самопроверки и конспект.
Узнать подробности

Для работы по HTTPS необходим сертификат. Если нет возможности/желания покупать - можно сгенерировать самому (разумеется, при входе все браузеры будут предупреждать о самопальности):

На *nix машине создаем сертификат сервера:

# openssl genrsa -out mikrotik.ca.key.pem 2048
# openssl req -new -x509 -nodes -days 9999 -key mikrotik.ca.key.pem -out mikrotik.ca.cert.pem

Копируем получившиеся файлы на Mikrotik (FTP или как угодно)

Импортируем сертификаты:

[[email protected]] > /certificate import file-name=mikrotik.ca.cert.pem
[[email protected]] > /certificate import file-name=mikrotik.ca.key.pem

Проверяем:

[[email protected]] > /certificate print 
Flags: K - private-key, D - dsa, L - crl, C - smart-card-key, A - authority, 
I - issued, R - revoked, E - expired, T - trusted 
 #          NAME    CO.. SUBJECT-ALT-NAME                                  FI..
 0 K      T cert_1  Ad.. email:[email protected]                            0a..

Включаем HTTPS:

[[email protected]] > /ip service set www-ssl certificate=cert_1
[[email protected]] > /ip service set www-ssl disabled=no

Проверяем:

[[email protected]] > /ip service print 
Flags: X - disabled, I - invalid 
 #   NAME                        PORT ADDRESS                                                         CERTIFICATE                    
 0 X telnet                        23
 1   ftp                           21 192.168.0.0/23                                               
 2 X www                           80
 3   ssh                           22
 4   www-ssl                      443                                                                 cert_1                         
 5 X api                         8728
 6   winbox                      8291 192.168.0.0/23                                               
 7 X api-ssl                     8729                                                                 none  

  • software/mikrotik/mikrotik-www-ssl.txt
  • Последнее изменение: 2020/11/09 01:30
  • (внешнее изменение)